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history and development of RiverTools · preparing a DEM for your study
area · kinds of information that can be extracted using RiverTools and
DEMs · special visualisation tools in RiverTools · what makes the RiverTools
software unique?

1. GETTING STARTED
RiverTools is a software toolkit with a user-friendly, point-and-click interface that
was speciﬁcally designed for working with DEMs and extracting hydrologic information from them. As explained in previous chapters, there is a lot of useful
information that can be extracted from DEMs since topography exerts a major
control on hydrologic ﬂuxes, visibility, solar irradiation, biological communities,
accessibility and many human activities. RiverTools has been commercially available since 1998, is well-tested and has been continually improved over the years
in response to the release of new elevation data sets and algorithms and ongoing feedback from a global community of users. All algorithms balance work
between available RAM and efﬁcient I/O to ﬁles to ensure good performance
even on very large DEMs (i.e. 400 million pixels or more). RiverTools is a product of Rivix LLC (www.rivix.com) and is available for Windows, Mac OS X and
Solaris.
RiverTools 3.0 comes with an installation CD and sample data CD but the
installer can also be downloaded from www.rivertools.com. It uses the industrystandard InstallShield installer and is therefore easy to install or uninstall. The
HTML-based help system and user’s guide includes a set of illustrated tutorials,
a glossary, step-by-step explanations of how to perform many common tasks, a description of each dialog and a set of executive summaries for major DEM data
sets and formats. All of the RiverTools ﬁle formats are nonproprietary and are explained in detail in an appendix to the user’s guide. In addition, each dialog has
a Help button at the bottom that jumps directly to the relevant section of the user’s
guide.
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The purpose of this chapter is to provide an overview of what RiverTools can
do and how it can be used to rapidly perform a variety of tasks with elevation
data. Section 1.1 explains the layout of the RiverTools menus and dialogs. Section 2
brieﬂy discusses GIS issues such as ellipsoids and map projections. Section 3 introduces some tools in the Prepare menu that simplify the task of preparing a DEM
that spans a given area of interest. Section 4 discusses how dialogs in the Extract
menu can be used to extract various grid layers and masks from a DEM. Section 5
highlights some of the visualisation tools in the Display menu and Section 5.1
introduces some of the Interactive Window Tools that can be used to query and
interact with an image.

1.1 The RiverTools menu and dialogs
RiverTools 3.0 can be started by double-clicking on a shortcut icon or by selecting
it from a list of programs in the Windows Start menu. After a startup image is displayed, the Main Window appears with a set of pull-down menus across the top
labeled: File, Prepare, Extract, Display, Analyze, Window, User and Help. Each pulldown menu contains numerous entries, and sometimes cascading menus with
additional entries. Selecting one of these entries usually opens a point-and-click
dialog that can be used to change various settings for the selected task. Buttons
labeled Start, Help and Close are located at the bottom of most dialogs. Clicking
on the Start button begins the task with the current settings. Clicking on the Help
button opens a browser window to a context-speciﬁc help page and clicking on
a Close or Cancel button dismisses the dialog.
The File menu contains tools for opening data sets, importing and exporting
data in many different formats, and for changing and/or saving various program
settings and preferences. The Prepare menu contains a collection of tools that can
be used at the beginning of a project to prepare a DEM for further analysis, such
as mosaicking and sub-setting tiles, replacing bad values, uncompressing ﬁles and
changing DEM attributes such as elevation units, byte order, orientation and data
type. The Extract menu contains a large set of tools for extracting new grid layers (e.g. slope, curvature and contributing area), vectors (e.g. channels and basin
boundaries) and masks (e.g. lakes and basins) from a DEM or a previously extracted grid layer. The Display menu has a collection of different visualisation tools
such as density plots, contour plots, shaded relief, surface plots, river network
maps, multi-layer plots and many more. Images can be displayed with any of 17
different map projections or without a map projection.
There is also an extensive set of Interactive Window Tools that makes it easy to
query and zoom into these images to extract additional information. The Analyze
menu has a number of tools for analysing and plotting terrain and watershed attributes that have been measured with the extraction tools. Graphics windows can
be managed with a set of tools in the Window menu and RiverTools can be extended
by users with plug-ins that appear in the User menu.
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2. ADVANCED GIS FUNCTIONALITY
2.1 Fixed-angle and ﬁxed-length grid cells
Virtually all elevation data providers distribute raster DEMs in one of two basic
forms. In the geographic or ﬁxed-angle form, the underlying grid mesh is deﬁned
by lines of latitude and longitude on the surface of a chosen ellipsoid model and
each grid cell spans a ﬁxed angular distance such as 3 arcsec. Lines of constant
latitude (parallels) and lines of constant longitude (meridians) always intersect
at right angles. However, since the meridians intersect at the poles, the distance
between two meridians depends on which parallel that you measure along. This
distance varies with the cosine of the latitude and is largest at the equator and
zero at the poles. So while each grid cell spans a ﬁxed angle, its width is a function
of its latitude. The ﬁxed-angle type of DEM is the most common and is used for
all global or near-global elevation data sets such as SRTM, USGS 1-Degree, NED,
DTED, GLOBE, ETOPO2, GTOPO30, MOLA and many others.
The second basic type of raster DEM is the “ﬁxed-length” form, where both the
east-west and north-south dimensions of each grid cell span a ﬁxed distance such
as 30 metres. This type of DEM is commonly used for high-resolution elevation
data that spans a small geographic extent so that the Earth’s surface can be treated
as essentially planar. They are almost always created using a Transverse Mercator
projection such as Universal Transverse Mercator (UTM). Examples include USGS
7.5-Minute quad DEMs, most LiDAR DEMs and many state and municipal DEMs.
When mosaicked to cover large regions, ﬁxed-length DEMs suffer from distortion
and lead to inaccurate calculations of lengths, slopes, curvatures and contributing
areas.

2.2 Ellipsoids and projections
Unlike most GIS programs, RiverTools always takes the latitude-dependence of
grid cell dimensions into account when computing any type of length, slope or
area in a geographic or ﬁxed-angle DEM. It does this by integrating directly on the
ellipsoid model that was used to create the DEM. In addition, when measuring
straight-line distance between any two points on an ellipsoid, the highly accurate
Sodano algorithm is used (Sodano, 1965). Other GIS programs project the ﬁxedangle elevation data with a ﬁxed-length map projection such as UTM and then
compute all length, slope and area measurements in the projected and therefore
distorted DEM.
In RiverTools, various properties of the DEM such as its pixel geometry (ﬁxedangle or ﬁxed-length), number of rows and columns and bounding box can be
viewed (and edited if necessary) with the View DEM Info dialog in the File menu.
When working with a ﬁxed-angle DEM, the user should set the ellipsoid model
to the one that was used in the creation of the original DEM data. This is done by
opening the Set Preferences dialog in the File menu and selecting the Planet Info
panel. A list of 51 built-in ellipsoid models for Earth are provided in a droplist,
as well as information for several other planets and moons. The ellipsoid models

414

S.D. Peckham

that were used to create several of the major DEM data sets is provided in the
RiverTools documentation. Most modern DEM data sets and all GPS units now
use the WGS84 ellipsoid model and this is the default. Since maps and images are
necessarily two-dimensional, RiverTools also offers 17 different map projections for
display purposes via the Map Projection Info dialog in the Display menu.

3. PREPARING DEMS FOR A STUDY AREA
3.1 Importing DEMs
Since elevation and bathymetric data is distributed in many different data formats, the ﬁrst step when working with DEMs is to import the data, that is, to
convert it to the format that is used by the analysis software. The DEM formats
that can currently be imported include: ARC BIL, ARC FLT, ENVI Raster, Flat Binary, SDTS Raster Proﬁle (USGS), USGS Standard ASCII, CDED, DTED Level 0,
1 or 2, GeoTIFF, NOAA/NOS EEZ Bathymetry, GMT Raster (netCDF), GRD98
Raster, ASTER, MOLA (for Mars), SRTM, ARC Gridded ASCII, Gridded ASCII,
and Irregular XYZ ASCII. While some DEMs simply store the elevations as numbers in text (or ASCII) ﬁles, this is an extremely inefﬁcient format, both in terms of
the size of the data ﬁles and the time required for any type of processing. Because
of this, elevation data providers and commercial software developers usually use
a binary data format as their native format and then provide a query tool such as
the Value Zoom tool in RiverTools for viewing DEM and grid values.
A simple, efﬁcient and commonly used format consists of storing elevation
values as binary numbers with 2, 4 or 8 bytes devoted to each number, depending
on whether the DEM data type is integer (2 bytes), long integer (4 bytes), ﬂoating
point (4 bytes) or double-precision (8 bytes). The numbers are written to the binary
ﬁle row by row, starting with the top (usually northernmost) row — this is referred
to as row major format. The size of the binary ﬁle is then simply the product of
the number of columns, the number of rows and the number of bytes used per
elevation value. All of the descriptive or georeferencing information for the DEM,
such as the number of rows and columns, pixel dimensions, data type, byte order,
bounding box coordinates and so on is then stored in a separate text ﬁle with the
same ﬁlename preﬁx as the binary data ﬁle and a standard three-letter extension.
This basic format is used by ARC BIL, ARC FLT, ENVI Raster, MOLA, SRTM,
RTG and many others. Many of the other common formats, such as SDTS Raster,
GeoTIFF and netCDF also store the elevation data in binary, row major format but
add descriptive header information into the same ﬁle, either before or after the
data.
To import a DEM into RiverTools, you choose Import DEM from the File menu
and then select the format of the DEM you want to import. If the format is one that
is a special-case of the RiverTools Grid (RTG) format (listed above), then the binary
data ﬁle can be used directly and only a RiverTools Information (RTI) ﬁle needs
to be created. You can import many DEMs that have the same format as a batch
job by entering a “matching wildcard” (an asterisk) in both the input and output
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ﬁlename boxes. For example, to import all of the SRTM tiles in a given directory or
folder that start with “N30”, you can type “N30*.hgt” into both ﬁlename boxes.
Elevation data is sometimes distributed as irregularly-spaced XYZ triples in
a multi-column text ﬁle. RiverTools has an import tool for gridding this type of
elevation data. In the current version, Delaunay triangulation is used but in the
next release six additional gridding algorithms will be added.

3.2 Mosaicking DEM tiles
The second step in preparing a DEM that spans a given area of interest is to mosaic many individual tiles to create a seamless DEM for the area. These tiles are
typically of uniform size and are distributed by DEM providers in separate ﬁles.
For example, SRTM tiles span a region on the Earth’s surface that is one degree
of latitude by one degree of longitude and have dimensions of either 1201×1201
(3 arcsec grid cells) or 3601×3601 (1 arcsec grid cells).
To mosaic or subset DEM tiles in RiverTools, you ﬁrst choose Patch RTG DEMs
from the Prepare menu. This opens an Add/Remove dialog that makes it easy to
add each of the tiles that you wish to mosaic to a list [Figure 1(a)]. Tiles can be
viewed individually by clicking on the ﬁlename for the tile and then on the Preview button. Similarly, their georeferencing information can be viewed by clicking
on the View Infoﬁle button. Tiles with incompatible georeferencing information
may sometimes need to be preprocessed in some way (e.g. units converted from
feet to metres or subsampled to have the same grid cell size) and this can easily be
done with the Convert Grid dialog in the Prepare menu.
The ﬁle selection dialog that is used to add tiles to the list provides a ﬁltering
option for showing only the ﬁles with names that match a speciﬁed pattern. This
dialog also allows multiple ﬁles to be selected at once by holding down the shift
key while selecting ﬁles. If these two features are used, even large numbers of tiles
can be rapidly added to the list. The Add/Remove dialog itself has an Options menu
with a Save List entry that allows you to save the current list of tiles to a text ﬁle.
You can then later select the Use Saved List option to instantly add the saved list
of ﬁles to the dialog.
Once you have ﬁnished adding DEM tiles to the list, you can type a preﬁx into
the dialog for the DEM to be created and then click on the Start button to display
the DEM Patching Preview Window [Figure 1(b)]. This shaded relief image in this
window shows how all of the tiles ﬁt together. You can then click and drag within
the image to select the subregion that is of interest with a “rubber band box”, or select the entire region spanned by the tiles by clicking the right mouse button. It is
usually best to select the smallest rectangular region that encloses the river basin of
interest. If you can’t discern the basin boundary, you can easily iterate the process
a couple of times since everything is automated. The DEM Patching Preview window has its own Options menu near the top and begins with the entry Save New
DEM. A button with the same label is also available just below the image. These
are two different ways of doing the same thing, namely to read data from each of
the DEM tiles to create a new DEM that spans the selected region. If there are any
“missing tiles” that intersect the region of interest (perhaps in the ocean) they are
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FIGURE 1 (a) The Patch RTG DEM dialog; (b) The DEM Patching Preview window with subregion
selected with a rubber-band box and both tiles labeled with ﬁlename preﬁxes.  2008 Rivix LLC,
used with permission.

automatically ﬁlled with nodata values. Other entries in the Options menu allow
you to do things like (1) label each tile with its ﬁlename, (2) “burn in” the rubber
band box and labels and (3) save the preview image in any of several common
image formats. Once your new DEM has been created, it is automatically selected
just as if you had opened it with the Open Data Set dialog in the File menu. You
can view its attributes using the View DEM Info tool in the File menu.

3.3 Replacing bad values
Sometimes a third step is required to prepare a DEM that spans a region of interest.
In SRTM tiles, for example, there are often nodata “holes” in high-relief areas that
were not in the line of sight of the instrument aboard the Space Shuttle that was

Geomorphometry in RiverTools

417

FIGURE 2 A yellow box and crosshairs on a shaded relief image shows the location of a hole
(red) in an SRTM DEM for Volcan Baru, Panama. The two images on the right show wire mesh
surface plots of the area near the hole, before and after using the Repair Bad Values tool. (See
page 740 in Colour Plate Section at the back of the book.)  2008 Rivix LLC, used with
permission.

used to measure the terrain heights. These holes usually span small areas between
1 and 20 grid cells but can be larger. For most types of analysis, these holes must be
repaired prior to further processing. RiverTools has a Replace Bad Values tool in the
Prepare menu that ﬁlls these holes with reasonable values by iteratively averaging
from the edges of the holes until the hole is ﬁlled. The output ﬁlename should
usually be changed to have a new preﬁx and the compound extension _DEM.rtg.
(Figure 2) shows the result of applying this tool to an SRTM DEM for Volcan Baru,
in Panama.

4. EXTRACTING LAND-SURFACE PARAMETERS AND OBJECTS FROM
DEMS
4.1 Extracting a D8 ﬂow grid
Once you have a DEM for an area of interest, there are a surprising number of
additional grid layers, polygons, proﬁles and other objects that can be extracted
with software tools and which are useful for various applications. Some of these
were discussed in Chapter 7. Figure 3 shows several land-surface parameters and
objects that were extracted for the Baranja Hill case study DEM and which will
be discussed throughout this section. A DEM with 5-meter grid cells was created
from a source DEM with 25-meter grid cells via bilinear interpolation followed by
smoothing with a 5×5 moving window, using the RiverTools Grid Calculator. This
smoother DEM was used for creating the images shown except for Figure 3(d).
A D8 ﬂow grid is perhaps the most fundamental grid layer that can be derived
from a DEM, as it is a necessary ﬁrst step before extracting many other objects.
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RiverTools makes it easy to create a D8 ﬂow grid and offers multiple options for resolving the ambiguity of ﬂow direction within pits and ﬂats. Choosing Flow Grid
(D8) from the Extract menu opens a dialog which shows the available options.
The default pit resolution method is “Fill all depressions”. In most cases, ﬁlling all
depressions will produce a satisfactory result since it handles the typically very
large number of nested, artiﬁcial depressions that occur in DEMs and even provides reasonable ﬂow paths through chains of lakes. However, support for closed

FIGURE 3 (a) Shaded relief image with labeled contour line overlay; (b) Shaded image of a D8
slope grid; (c) Shaded image of a total contributing area grid, extracted using the mass ﬂux
method; (d) Drainage pattern obtained by plotting all D8 ﬂow vectors; (e) Watershed subunits
with overlaid contours and channels (blue), using a D8 area threshold of 0.025 km2 ; (f) Shaded
image of plan curvature, extracted using the method of Zevenbergen–Thorne. (See page 741 in
Colour Plate Section at the back of the book.)  2008 Rivix LLC, used with permission.
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(continued)

basins is also provided and is necessary for cases where ﬂow paths terminate in
the interior of a DEM, such as at sinkholes, land-locked lakes or craters. The default ﬂat resolution method is “Iterative linking”. As long as the entire boundary
of a river basin is contained within the bounding box of the DEM, each of the ﬂat
resolution methods will almost always produce ﬂow directions within ﬂat areas
of the basin that send water in the right direction, despite the absence of a local
elevation gradient (see the discussion of edge effects in Chapter 7).
Within broad, ﬂat valleys, however, the “iterative linking” method Jenson (1985,
1991) produces multiple streamlines that ﬂow parallel to one another until there
is a bend in the axis of the valley that causes them to merge. The main problem
with these parallel ﬂow paths is that the point at which one stream merges into another (the conﬂuence) is often displaced downstream a considerable distance from
where it should be. The “Imposed gradients” option uses the method published by
Garbrecht and Martz (1997) to create a cross-valley elevation gradient in ﬂats and
tends to produce a single ﬂow path near the centre of the valley. However, this
method sometimes results in two parallel ﬂow paths near the centre of valleys instead of one. The “Imposed gradients plus” option was developed by Rivix to merge
any parallel ﬂow path pairs (in ﬂats) into a single ﬂow path.
N OTE . Increasing the vertical or horizontal resolution of DEMs does not eliminate
artiﬁcial pits and ﬂats and can even increase their numbers.

4.2 Extracting and saving a basin outlet
Once you have created a D8 ﬂow grid, there is an easy-to-use graphical tool in
RiverTools for precisely selecting which grid cell you want to use as a basin outlet.
Choosing Basin Outlet from the Extract menu opens a dialog. Clicking on the dialog’s Start button produces an image (shaded relief or density plot) that shows
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the entire DEM. If you then click within the image window, a streamline from the
place where you clicked to the edge of the DEM will be overplotted on the image.
You can move the mouse and click again to select and plot another streamline.
Some of the streamlines will ﬂow into the main channel of your basin of interest
and some will ﬂow into other, disjoint basins. Once you have selected a streamline
that ﬂows through the point you wish to use as a basin outlet, you can then use
the slider in the dialog to move a red/white indicator along the streamline to your
desired basin outlet point.
The precise grid cell coordinates are printed in the Output Log window, and
you can click on the arrow buttons beside the slider to select any grid cell along
the streamline, even if the image dimensions are many times smaller than the DEM
dimensions. This graphical tool is designed so that you are sure to select a grid cell
for the basin outlet that lies along any streamline that you select, instead of a few
pixels to one side or the other. Once you have selected a grid cell as a basin outlet
with this two-step graphical process, you simply click on the Save Outlet button in
the dialog to save the coordinates in a text ﬁle with the extension “_basin.txt”.
These coordinates identify the watershed that is of interest to you and are used
by subsequent processing routines. Additional basic info for the basin will be appended to this ﬁle as you complete additional processing steps. By allowing any
number of basin preﬁxes in addition to the data preﬁx associated with the DEM ﬁlename, RiverTools makes it easy to identify several watersheds in a given DEM and
extract information for each of them separately while allowing them to share the
same D8 ﬂow grid and other data layers. You can change the basin preﬁx at any
time using the Change Basin Preﬁx dialog in the File menu. This tells RiverTools
which watershed you want to work with.

4.3 Extracting a river network
A river network can be viewed as a tree graph with its root at a particular grid
cell, the outlet grid cell. The Extract → RT Treeﬁle dialog extracts the “drainage tree”
for the watershed that drains to the outlet grid cell that you selected previously
and saved. This is a raster to vector step that builds and saves the topology of the
river network and also measures and saves a large number of attributes in a RiverTools vector (RTV) ﬁle with compound extension _tree.rtv. The Extract → River
Network dialog can then be used to distinguish between ﬂow vectors on hillslopes
and those that correspond to channels in a river network. The ﬂow vectors on the
hillslopes are pruned away and the remaining stream channels are saved in another
RTV ﬁle with extension _links.rtv, along with numerous attributes. A variety
of different pruning methods have been proposed in the literature and each has
its own list of pros and cons. Figure 4 shows a river network extracted from SRTM
data for the Jing River in China.
RiverTools supports pruning by D8 contributing area, by Horton–Strahler order, or by following each streamline from its starting point on a divide to the ﬁrst
inﬂection point (transition from convex to concave). In addition, you can use any
grid, such as a grid created with the Grid Calculator (via Extract → Derived Grid)
together with any threshold value to deﬁne your own pruning method. The real
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Jing River in the Loess Plateau of China, extracted from SRTM data with 3-arcsec grid

test of a pruning method is whether the locations of channel heads correspond to
their actual locations in the landscape, and this can only be veriﬁed by ﬁeld observations. Montgomery and Dietrich (1989, 1992) provide some guidance on this
issue. See Figure 4 in Chapter 7 for additional information on pruning methods.
Once you have completed the Extract → RT Treeﬁle and Extract → River Network processing steps, you will ﬁnd that your working directory now contains
many additional ﬁles with the same basin preﬁx and different ﬁlename extensions.
Each of these ﬁles contains information that is useful for subsequent analysis.
Three of these ﬁles end with the compound extensions _tree.rtv, _links.rtv
and _streams.rtv. These RTV ﬁles contain network topology as well as many
measured attributes. For example, the attributes stored in the stream ﬁle for each
Horton–Strahler stream are: upstream end pixel ID, downstream end pixel ID,
Strahler order, drainage area, straight-line length, along-channel length, elevation drop, straight-line slope, along-channel slope, total length (of all channels
upstream), Shreve magnitude, length of longest channel, relief, network diameter,
absolute sinuosity, drainage density, source density, number of links per stream,
and number of tributaries of various orders. RTV ﬁles and their attributes can
also be exported as shapeﬁles with the Export Vector → Channels dialog in the File
menu.

4.4 Extracting grids
4.4.1 D8-based Grids
Once you have a D8 ﬂow grid for a DEM, there are a large number of additional
grid layers that can be extracted within the D8 framework. RiverTools currently
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FIGURE 5 A relief-shaded image of a TCA grid for Mt. Sopris, Colorado, that was created using
the Mass Flux method. Areas with a large TCA are shown in red while areas with a small TCA
value (e.g. ridgelines) are shown in blue and purple. Complex ﬂow paths are clearly visible and
results are superior to both the D8 and D-inﬁnity methods. (See page 742 in Colour Plate
Section at the back of the book.)  2008 Rivix LLC, used with permission.

has 14 different options in the Extract → D8-based Grid menu. D8 area grids and
slope grids are perhaps the best-known (see Chapter 7), but many other useful
grid layers can be deﬁned and computed, including grids of ﬂow distance, relief,
watershed subunits and many others. Each of these derived grids inherits the same
georeferencing information as the DEM.

4.4.2 D-Inﬁnity Grids
As explained in Chapter 7, the D-Inﬁnity algorithms introduced by Tarboton
(1997) utilise a continuous ﬂow or aspect angle and can capture the geometry of
divergent ﬂow by allowing “ﬂow” to more than one of the eight neighbouring grid
cells. These grids can be computed in RiverTools by selecting options from the Extract → D-Inﬁnity Grid menu.

4.4.3 Mass Flux Grids
As also explained in Chapter 7, the RiverTools Mass Flux algorithms provide an
even better method for capturing the complex geometry of divergent and convergent ﬂow and its effect on total contributing area (TCA) and speciﬁc contributing
area (SCA). These grids can be computed in RiverTools by selecting options from
the Extract → Mass Flux Grid menu. Figures 5 and 3(c) show examples of contributing area grids computed via this method. Figure 6 shows continuous-angle ﬂow
vectors in the vicinity of a channel junction or fork that were extracted using the
Mass Flux method and then displayed with one of the interactive window tools.
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FIGURE 6 Continuous-angle ﬂow vectors in the vicinity of a channel junction or fork,
extracted using the Mass Flux method.  2008 Rivix LLC, used with permission.

4.4.4 Finite Difference Grids
RiverTools can compute many standard morphometric parameters such as slope,
aspect, ﬁrst and second derivatives, and ﬁve different types of curvature. It currently does this using the well-known method of Zevenbergen and Thorne (1987)
that ﬁts a partial quartic surface to the (3×3) neighbourhood of each pixel in the
input DEM and saves the resulting grid as a RiverTools Grid (RTG) ﬁle. Additional
methods are planned for inclusion in the next release. These grids can be computed by selecting options from the Extract → Finite Difference Grid menu.

4.4.5 Other Derived Grids

The Extract → Derived Grids menu lists several other tools for creating grids. The
most powerful of these is the Grid Calculator that can create a new grid as a function of up to three existing grids without requiring the user to write a script. For
example, it can be used to create any type of wetness index grid from grids of slope
and speciﬁc area. The dialog resembles a standard scientiﬁc calculator. In addition
to the operators shown, any IDL command that operates on 2D arrays (i.e. grids)
can be typed into the function text box. The Restricted to RTM tool lets you create
grids in which masked values are reassigned to have nodata values. For example,
this tool can be used to create a new DEM in which every grid cell that lies outside
of a given watershed’s boundary is assigned the nodata value.

4.5 Extracting masks or regions of interest
Within grid layers one often wishes to restrict attention or analysis to particular
regions of interest or polygons, such as watersheds, lakes, craters, or places with elevation greater than some value. In order to display or perform any kind of analysis
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for such a region, we need to know which grid cells are in the region and which are
not. This is equivalent to knowing the spatial coordinates of its boundary. A large
number of different attributes can be associated with any such polygon, such as
its area, perimeter, diameter (maximum distance between any two points on the
boundary), average elevation, maximum ﬂow distance or centroid coordinates.
RiverTools Mask (RTM) ﬁles provide a simple and compact way to store one or
more masked regions in a ﬁle. A complete description of RTM ﬁles is given in an
appendix to the user’s guide.
There are a number of different tools in the Extract → Mask submenu that can
be used to create RTM ﬁles. For example, watershed polygons of various kinds can
be extracted with the Sub-basin Mask tool, lake polygons can be extracted with
the Connected-to-Seed Mask tool, and threshold polygons can be extracted with

(a)

(b)
FIGURE 7 Functions extracted from a DEM for Beaver Creek, Kentucky: (a) an area–altitude
plot and (b) an area–distance plot.
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the Grid Threshold Mask tool. Creative use of these tools can solve a large number
of GIS-query problems. RTM ﬁles that record the locations of single or multi-pixel
pits are created automatically by the Extract → Flow Grid (D8) tool. A tesselation of
watershed subunits can be created with the Extract → D8-based Grid → Watershed
Subunits tool. RTM ﬁles can also be merged by the Merge Files tool in the Prepare
menu. Given an RTM ﬁle for a region of interest, the Export Vector → Boundaries
tool in the File menu can create an ESRI shapeﬁle for the polygon and can also
compute and save 36 optional attributes (new in the next release).

4.6 Extracting functions
Hypsometric curves or area–altitude functions have a long history (Strahler, 1952;
Pike and Wilson, 1971; Howard, 1990) and RiverTools can extract this and several other functions from a DEM (Figure 7). The width function (Kirkby, 1976;
Gupta et al., 1980; Troutman and Karlinger, 1984) and closely related area–distance
function measure the fraction of a watershed (as number of links or percent area)
that is at any given ﬂow distance from the outlet (Extract → Function menu) and
are tied to the instantaneous unit hydrograph concept. The cumulative area function (Rigon et al., 1993; Peckham, 1995b) measures the fraction of a watershed
that has a contributing area greater than any given value (Extract → Channel Links
→ Link CDF). Empirical cumulative distribution functions (ECDFs) (Peckham, 1995b;
Peckham and Gupta, 1999) for ensembles of basins of different Strahler orders
have been shown to exhibit statistical self-similarity: Analyze → Strahler streams →
Stream CDFs. It has been suggested by Willgoose et al. (2003) that some of these
functions can be used together to measure the correspondence between real and
simulated landscapes.

5. VISUALISATION TOOLS
RiverTools has a rich set of visualisation tools, many of which are centrally located
in the Display menu. Each tool provides numerous options which are explained in
context-speciﬁc help pages, available by clicking on the Help button at the bottom
of the dialog. After changing the settings in the dialog, you click on the Start button to create the image. There are too many display tools and options to describe
each one in detail here, so the purpose of this section is to provide a high-level
overview. Many of the tools have their own colour controls, but colour schemes
can also be set globally with the Set Colors dialog and saved with the Set Preferences dialog. Both of these are launched from the File menu. Most of the images
created by tools in the Display menu can be shown with a map projection, and
the projection can be conﬁgured with the Map Projection Info dialog at the bottom
of the menu. Menus labelled Options, Tools and Info at the top of image windows
provide additional functionality, such as the ability to print an image or save it in
any of several popular image formats. The Tools menu contains a large number of
Interactive Window Tools that will be highlighted in the next section.
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FIGURE 8 High-resolution MOLA (Mars Orbiter Laser Altimeter) DEM displayed in RiverTools:
colour shaded relief image for planet Mars shown by the cylindrical equidistant map projection.
(See page 743 in Colour Plate Section at the back of the book.)

The Density Plot tool creates colour-by-number plots, and offers many different types of contrast-enhancing ‘stretches’ including linear, logarithmic, power-law
and histogram equalisation. For example, contributing area grids are best viewed
with a power-law stretch, due to the fact that there are a small number of grid cells
with very large values and a large number with very small values. The Contour
Plot tool makes it easy to create either standard or ﬁlled contour plots (or both as
a multi-layer plot) and provides a large number of options such as the ability to
control the line style, width and colour of each contour line. Colour shaded relief
images with different colour tables and lighting conditions can easily be created
with the Shaded Relief tool (Figure 8). There is also a tool called Shaded Aspect that
simply uses D8 ﬂow direction values with special colour tables to visualise DEM
texture. A Masked Region tool allows you to display the boundaries or interiors of
one or more “mask cells” or polygons (e.g. basins, pits, lakes, etc.) which are stored
in RTM (RiverTools Mask) ﬁles with the extension .rtm. A related tool is the ESRI
Shapeﬁle tool which has numerous options for plotting vector data that is stored in
a shapeﬁle, including points, polylines and polygons. (Shapeﬁles may be created
from RTV and RTM ﬁles with the Export Vector → Channels and Export Vector →
Boundaries tools in the File menu.) A button labeled View Attr. Table at the bottom
of this dialog displays a shapeﬁle’s attribute table, and the table can be sorted by
clicking on column headings. Digital Line Graph (DLG) data in the now-standard
SDTS format can be displayed by itself or as a vector overlay with the DLG–SDTS
tool.
The Function tool in the Display menu reads data from a multi-column text
ﬁle and creates a plot of any two columns. There are several places in RiverTools
where data can be saved to a multi-column text ﬁle (e.g. longitudinal proﬁles) and

Geomorphometry in RiverTools

427

later displayed with this tool. Perspective-view plots for an entire DEM can be
displayed with the Surface Plot tool as wire-mesh, lego-style or shaded. For larger
DEMs, however, better results are obtained with the Surface Zoom window tool
which is explained in the next section. Extracted river networks, which are saved
in RTV (RiverTools Vector) ﬁles can be displayed with the River Network tool, or
ﬁrst exported via File → Export Vector → Channels and displayed with the ESRI
Shapeﬁle tool. Using the Multi-Layer Plot tool, images created by many of the tools
in the Display menu can be overlaid, that is, any number of vector plots can be
overlaid on any raster image.
One of the most powerful tools in the Display menu is the Grid Sequence tool.
This tool is for use with RTS (RiverTools Sequence) ﬁles, which are a simple extension1 of the RTG (RiverTools Grid) format. RTS ﬁles contain a grid sequence, or
grid stack, usually with the same georeferencing as the DEM. Grids in the stack
are usually indexed by time and are typically created with a spatially-distributed
model that computes how values in every grid cell change over time. For example, a distributed hydrologic model called TopoFlow2 can be used as a plug-in to
RiverTools (see Chapter 25). TopoFlow computes the time evolution of dynamic
quantities (e.g. water depth, velocity, discharge, etc.) and can save the resulting
sequence of grids as an RTS ﬁle. Landscape evolution models also generate grid
stacks that show how elevations change over time. This tool can show a grid stack
as an animation or save it in the AVI movie format. It allows you to jump to a particular frame, change colours and much more. The Options menu at the top of the
dialog has many additional options and there is also a Tools menu that has tools
for interactively exploring grid stack data, such as the Time Proﬁle and Animated
Proﬁle tools.

5.1 Interactive window tools
As mentioned previously, image windows that are created with the tools in the
Display menu typically have three menus near the top of the window labelled
Options, Tools and Info. In RiverTools, the entries in an Options menu represent
simple things that you can do to the window, such as resize it, print it, close it or
save the image to a ﬁle. The entries in a Tools menu represent ways that you can
use the mouse and cursor to interact with or query the image. Here again we will
simply give a high-level overview of several of these tools, but more information
is provided in the user’s guide.
The Line Proﬁle tool lets you click and drag in an image to draw a transect and
then opens another small window to display the elevation values along that transect. Note that this new window has its own Options menu that lets you do things
like save the actual proﬁle data to a multi-column text ﬁle. The Channel Proﬁle tool
is similar (Figure 9), except that you click somewhere in the image and then the
ﬂow path or streamline from the place where you clicked to the edge of the DEM is
overlaid on the image. The elevations (or optionally, the values in any other grid)
1 All of the RiverTools formats are nonproprietary and are explained in detail in an appendix to the user’s guide.
2 http://instaar.colorado.edu/topoﬂow/.
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FIGURE 9 Longitudinal proﬁle plot created for a main channel of the Beaver Creek DEM with
the Channel Proﬁle tool.

along that streamline are plotted vs. distance along the streamline in another small
window. Again, the Options menu of this new window has numerous entries.
The Reach Info tool is similar to the Channel Proﬁle tool but opens an additional
dialog with sliders that let you graphically select the upstream and downstream
endpoints of any reach contained within the streamline and displays various attributes of that reach. If you select Vector Zoom from the Tools menu and then click
in the image, crosshairs are overlaid on the image and a small window is displayed
that shows grid cell boundaries, D8 ﬂow paths and contour lines in the vicinity of
where you clicked.
The Value Zoom tool is similar but displays actual grid values as numbers and
also shows the coordinates of the selected grid cell (Figure 10). This tool has many
other capabilities listed in its Options menu, such as the ability to edit grids or
jump to speciﬁed coordinates. Perspective, wire mesh plots are more effective
when applied to smaller regions rather than to entire DEMs, so the Surface Zoom
tool provides a powerful way to interactively explore a landscape (Figure 11). This

FIGURE 10

The Value Zoom dialog.
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The Surface Zoom display window.

tool has many settings at the bottom of the display window and many entries in
its Options menu. The Density Zoom and Relief Zoom tools show density plots (see
last section) and shaded relief plots at full resolution for a selected region even
though the main image may show the entire area of the DEM at a greatly reduced
resolution. All of the Zoom-tools are automatically linked, so that they all update
when you move the mouse to another location in the image. The Add Scale Bar, Add
Colour Bar, Add Text and Add Marker tools can be used to interactively annotate an
image prior to saving it to an image ﬁle with Options → Save Window.
Finally, the Flood Image tool allows you to change the colour of all pixels below a given elevation to blue, either instantly or as an animation. It is a useful
visualisation tool but does not model the dynamics of an actual ﬂood.

6. SUMMARY POINTS
RiverTools is a powerful but easy-to-use toolkit for visualising and extracting information from digital elevation data. It has an intuitive, point-and-click graphical interface, an extensive HTML-based help system and much of the power of
a full-featured GIS even though its main focus is on digital elevation data. It also
contains state-of-the-art algorithms for computing geomorphometric quantities,
such as the new Mass Flux method for computing contributing area. This unique
combination of features makes it ideal for teaching courses in hydrology, landscape ecology and geomorphology. RiverTools can import a wide variety of DEM
formats as well as vector data in the ESRI shapeﬁle and DLG-SDTS formats. It
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works well together with other GIS software since it can also export raster data in
several common formats (via File → Export Grid) and vector data in the industrystandard shapeﬁle format (via File → Export Vector). Publication-quality graphics
and posters are easily created and annotated. Many built-in features including
a graphical Grid Calculator and support for wildcards in many places where an
input ﬁlename is required (to allow batch processing) mean that writing scripts is
usually not necessary. However, in cases where scripting is required, users have
the option to purchase another product called IDL (Interactive Data Language,
a product of ITT Visual Information Solutions, www.ittvis.com) that can be used
to write extensions to RiverTools. This option provides access to all of the features of the IDL programming language in addition to a large set of documented,
low-level RiverTools commands for customisation. Users can also extend RiverTools
with free User menu plug-ins, such as a landscape evolution model called Erode
and a spatially-distributed hydrologic model called TopoFlow.
RiverTools has been developed and reﬁned over many years around three central themes, namely (1) ease of use, (2) ability to handle very large DEMs (whatever
the task) and (3) accuracy of measurements. With regard to ease of use, Rivix has
worked with users for many years to develop a user-friendly graphical interface
and HTML help system. As for the ability to rapidly extract information from very
large DEMs, this has driven the development of advanced algorithms that efﬁciently distribute the computational workload between available RAM and I/O to
ﬁles. These types of algorithms are used throughout RiverTools. Finally, RiverTools
and MicroDEM may be the only GIS applications that always take the latitudedependence of pixel geometry into account when working with geographic DEMs.
All lengths, slopes and areas are computed by integrating on the surface of the appropriate ellipsoid model to avoid the geometric distortion that is associated with
map projections. This feature is especially important when working with DEMs at
the regional, continental or global scale.

IMPORTANT SOURCES
Rivix LLC, 2004. RiverTools 3.0 User’s Guide. Rivix Limited Liability Company, Broomﬁeld, CO,
218 pp.
http://rivertools.com — RiverTools website.
http://instaar.colorado.edu/topoﬂow/ — TopoFlow website.
http://www.ittvis.com — ITT Visual Information Solutions.

